Ruby-FFI 1.0.0 からは Ruby 1.9.2 以降が必要になった

2010/12/16 12:00am

Ruby-FFI 1.0.0 からは Ruby 1.9.2 以降が必要になった

% sudo gem1.8 install ffi
Password:
ERROR:  Error installing ffi:
        ffi requires Ruby version >= 1.9.2

そのため、Ruby 1.8 向けの gem をインストールするときはバージョン 0.6.3 を指定する。

% sudo gem1.8 install ffi --version "= 0.6.3"
Password:
Building native extensions.  This could take a while...
Successfully installed ffi-0.6.3
1 gem installed
Installing ri documentation for ffi-0.6.3...
Installing RDoc documentation for ffi-0.6.3...